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Chapter 1: Preface

1.1 Introduction
Samhita® Enterprise Document Management software offers an organization wide platform for 
capturing, creating, managing, retrieving and archiving large volumes of documents. 

Samhita® incorporates best practices to redefine the transition from an office based on paper 
documents to an office based on electronic documents. Samhita® not only helps organizations 
manage the increasing volumes of paper documents; it also provides a platform to organize and 
monitor unstructured data.

An  integral  part  of  the  DBSentry  Corp’s  product  suite,  Samhita  Enterprise  Document 
Management offers a wide range of functionalities, which help organizations reduce misfiling, 
document retrieval time and costly photocopying and paper distribution – all processes that 
impede information access.

The electronic document management features in Samhita are essential functionality for the 
organization and maintenance of files and documents. The web based document management 
software from DBSentry Corp. brings a number of benefits to end users working or managing 
documents throughout the document life cycle.

Benefits of Samhita includes:
Secured Document Access
Samhita®  incorporates  industry  standard  security  features  that  allows  secure  control  and 
authorization of users as they access documents. Samhita® security features provides a tight 
control of who can access what folders, documents and information and the degree of access 
they  can  have  (read,  add,  edit,  delete  and  Admin).  It  also  provides  advance  security  to  a 
granular level by providing encryption on documents, which gives option to access Folders, but 
restrict access to documents within the Folders. 

User Access Audit Report
Samhita® incorporates an essential requirement for regulatory compliance – of who added or 
read  the  document  /  record  or  when it  was  deleted  from the  repository.  It  also  tracks  the 
movement of the documents through a document life cycle with proof of access and changes at 
every stage of the process and the cycle.

Document Version Control
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Samhita® provide an easy to use Check in/ Check out facility that prevents documents from 
being overwritten or deleted as documents are updated. Document can be easily rolled back to 
their previous versions as and when required. All the versions are maintained and can be viewed 
from within the browser. Each document version allows user to track the timing of when the 
versions were added and who added them.

Document Watch
Users can subscribe to documents or folders using this feature. This allows users or a user group 
to be notified of changes or addition of documents in Samhita®. Users can manage all the 
document subscription of watch from a central list.

Retrieve critical documents faster
Samhita® provides advanced document search and retrieval features to ensure that users are 
more productive than before as the search time reduces drastically. There are multiple search 
options provided by Samhita® to make sure, User get the information they are looking for how 
they want it whenever they want it.

Centralized Storage
Samhita® provides a centralized repository to streamline the management of mission critical 
documents maintaining current and effective versions of business documents.

In this chapter we shall look into the following topics:

Starting Samhita

Login

Elements on User's Home page

Logout

1.2 Starting Samhita:
You  can  use  any  web  browser  (Internet  Explorer,  Firefox)  to  access  Samhita  Document 
Management System. Launch a web browser of your choice and point to the Samhita URL (Ask 
your system administrator for the URL). You will be presented with the Samhita login screen.
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1.3 Login:
• Launch Smahita URL using your favorite web browser

• Enter your userid and password

• Click on “OK” button
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1.4 Elements on User Home Page:
The following table describe various elements on Samhita User Home Page.

Screen 
Element

Description

Help Link to context sensitive help. This element is present on every screen.
Preferences Link to user preferences window. This element is present on every screen.
Logout Logout Link. This element is present on every screen.

9

Illustration 2: Samhita User Home Page



Screen 
Element

Description

user

Link to User administration page

group

Link to Group administration page

themes

Link to a page where custom theme can be defined.

security

Link to document/user security page

adapter

Link to adapter page that integrates samhita with your other information 
systems (For e.g. Peoplesoft Financials).

documents

Link to document management page.

scheduler

Link to scheduler page where you can monitor status of your email/fax jobs.

email

Link to email page where you can email documents

fax

Link to fax page where you can fax documents

Workflow

Link to workflow page.

1.5: Logout
• Click on the “Logout” link on the top right of the page to logout of the Samhita app.
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Chapter 2: Document Management

In this chapter we shall look into the following topics:

Introduction

Elements on Toolbar

How to use address bar

How to use navigation panel

How to use folder/document list

How to Search

How to create a new document

How to create a new folder

How to rename a folder/document

How to upload a document

How to download a document

How to apply an ACL to a document/folder

How to create a permanent/transient link to a document

How to view document/access log

How to activate a watch feature on a document

How to view a document as HTML document

How to Cut/Copy/Paste a document/folder

How to delete a document/folder

How to copy a document/folder to a new location

How to move a document/folder to a new location

How to make a document versionable

How to check-out a document

How to check-in a document
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How to undo a checkout on a document

How to view version history of a document

How to encrypt a document

How to decrypt a document

How to zip a document/folder

How to unzip a document/folder

How to email a document

How to fax a document

How to submit a document/folder to a workflow

2.1 Introduction:
To access Document Management explorer, while Logging in, select Document icon   to 
view the folders/documents listing for the logged-in user, and the shared document for that user. 

Document/Folder page consists of following parts. 
• Tool-bar   consists  of  icons  which  assists  you  to  perform  various  operations  on 

Folder/Document List.

• Menu-bar   consists  of  drop  down  lists  which  assists  you  to  various  operations  on 
Folder/Document Lists.

• Address-bar   assists you to navigate through the folders by directly entering the path of 
the folder separated by '/ '.

• Navigation  Panel   consists  of  Tree  view  which  lists  the  folders.  You  can  navigate 
through the folders by selecting the folders icon. 

• Folder/Document List Panel   consists of listing of folder and documents. 

• Search Panel   consists of various search criteria's. You can search for the documents.
• Status-bar consists of two parts   

• Message-bar: displays  the  message  of  the  operations  performed  on  the 
Folder/Document List.

• Navigation-bar: helps in navigating through the result when the total items are 
more than the displayed items 
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2.2 Elements on Toolbar:
The following table describes various elements on the toolbar

Element Description
New Document

New Folder
Change name of folder/document
Upload a file
Download a file
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Element Description
Apply ACL to document or folder
View file or folder property
Generate a permanent or a transient link to a document or a folder
View document log
Add a watch on a document
View a document as an HTML document
Cut
Copy
Paste
Delete
Copy to
Move to
Make a document versionable
Check-Out
Check-in
Undo check-out
View version history
Encrypt
Decrypt
Zip 
Unzip
Email a document
Fax a document
Submit a document or folder to a workflow.
Back
Forward
Go a level on top from the current level
Search
Refresh
Go to user home
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2.3 How to use Address Bar:

• Enter the path where you would like to navigate.

• Press 'Go' icon to go to display the record of the entered path. 

• Folder/Document will be displayed corresponding to the path entered. 

2.4 How to use Navigation Panel:
• '/ ' indicates root folder. 

• '-' indicates expanded state of the folder. Clicking on it will hide 
the sub folders. 

• '+' indicates collapsed state of the folder. Clicking on it will display 
the sub folders. 

• Clicking on the folder will display the contents of the folder in the 
Folder/Document List on the right-hand side. 

• Open Folder indicates that the contents of the folder are displayed 
in the Folder/Document List and vice-versa. 
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2.5 How to use Folder/Document List:

*Above displayed icons are: 

• Folder [  ] 

• Document [  ] 

• Checked-Out Document [  ] 

• Versioned Document [  ] 

• To see the content of the folder click on the text of the corresponding icon.

• To view the document click on the text of the corresponding icon.

• To view the folder above the displayed folder click up icon. 

• You can navigate through the Folder/Document List using the Previous, Next, Up icons, 
it view the corresponding pages. 

2.6 How to Search a folder/document
Click on Search [  ] to bring up the search screen

• Search for Folders & Documents :    Enter the name of the folder/document to be searched

• Description/Keyword:   Enter the description/keyword of folder/document to be searched.

• Containing Text:   Enter the containing text of the document to be searched.

• Look In:   Enter the path where the search has to be performed

•  Select the path where search has to be performed using look-up next to the Look In text.
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• Search:   Press 'Search' to perform the search based on 
the criteria entered.

• Stop:   Press 'Stop' to stop the search.

• Reset:   Press 'Reset' to reset entries to enable another 
search.

• Date:   Check this option to search folder/document 
based on date entered in From or/and To Date. 
You can select date using look-up next to the 'from/to 
Textbox'. 

• Type:   Check this option to specify the type of 
document to be searched like doc. 

• Size:   Check this option to search 
folder/document based on the size. 

• Advanced Options:   Check this option to search 
folder/ document using either "Search Sub 
Folders" or "Case Sensitive" search or both. 

2.7 How to create a new document
• Please note that this funcionality is accessible only through Microsoft Internet Explorer. 

• In Folder/Document List click the folder where you would like to create new document. 

• Click on the 'Create New Document' icon [  ] 

• It  is  possible  to  create  a  new  MSWord  document,  a  new  MSExcel  document,  a  new 
MSPowerPoint  presentation or  a  new Text  document  (Refer  the  figure  below in  clockwise 
sense). 

• Click on the document type icon shown below to start the procedure. 

• The user will be prompted with the new document window shown below. 
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• Enter the name of the document.

• Press 'Ok' to create new document.

• Enter your network id and password when prompted to do so.

• The application corresponding to the selected document type will be initiated.

• The user can then proceed to create his/her document and save it.

• Press 'Cancel' to abort creating new document.

Not able to create new document? 
• Insufficient rights to create new document in the selected location.

• Try creating new document in your Home Folder.

• Or Contact system Administrator.

2.8 How to create a new folder
• In Folder/Document List click the folder where you would like to create new folder. 

• Click on the 'New Folder' icon [  ] or select from menu File->New Folder. 

• Enter the name of the folder.

• Enter the description of the folder(optional)

• Press 'Ok' to create new folder.

• Press 'Cancel' to abort creating new folder.

Not able to create New Folder 
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• Insufficient rights to create New Folder in the selected location.

• Try creating New Folder in your Home Folder.

• Or Contact system Administrator.

2.9 How to rename a folder/document
• From the Folder/Document List select the folder/document to be renamed. 

• You can select multiple folders/documents. 

• Click on the 'Rename' icon [  ] or select from menu Edit->Rename. 

• Old name, Current name(Rename To), Description are displayed for each selection. 

• Enter the name to which you would like to rename.

• Enter new description for the same(optional).By default, the original description is displayed(if 
any).

• Press 'Ok' to bring into effect the names and descriptions you have changed.

• Press 'Cancel' to abort renaming. 

2.10 How to upload a document
• In Folder/Document List click the folder where you would like to upload new file. 

• Click on the upload icon [ ] or select from menu File->Upload File. 
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• Press 'Browse' to select the file to be uploaded from your system. 

• Select the file to be uploaded. 

• Enter the description. (optional) 

• Press 'Add' to add the file in file-list . 

• Press 'Remove' to remove selected file(s) from file-list. 

• Press 'Upload' to upload file(s) from file-list. 

• Press 'Cancel' to abort uploading. 

2.11 How to download a document
• From the document list select documents you want to download

• Click on download icon [ ] to download the files

2.12 How to apply an ACL to a document/folder
• In Folder/Document List select the folder/document on which you would like to apply ACL.

• You can select multiple folder/document.
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• Click on the 'Apply ACL' icon [  ] or select from menu File->Apply ACL.

• Select an ACL to be applied on Folder/Document or search an ACL by giving the keyword.
(Enter a word in the text box and click Search. You can also use wild card "*")

• Apply Recursively - Check this option if you would like to apply ACL on sub Folders and 
documents. 

• Press 'Select' to apply ACL on the Folder/Document. 

• Press 'Cancel' to abort applying ACL. 

2.13 How to view property of Folder/Document:
• In Folder/Document List select the folder/document for which you would like to see the 

Property. 

• You can select multiple folders/documents. 

• Click on the Property icon [  ] or select from menu File->Property. 
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• You can rename the folder/document or apply another ACL to it. 

• Press 'OK' to save the changes made. 

• Press 'Cancel' to abort 'Rename' or applying 'ACL'. 

2.13 How to create a permanent/transient link to a document
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• From the Folder/Document List select the items for whom links are to be generated.

• Click on the generate link(s) icon [  ] or select from menu: File ->Generate Link(s).For 
every item selected, there are 3 options,which are explained below .

• Link Expires On: Select the date on which this item's link will be rendered ineffective in 
displaying it's contents.(It is assumed that the link will then expire at 23:59:59 on the selected 
date. )

• Allow [] Downloads: An editable dropdown that will enable you to set the number of times the 
link would work. After which the link would expire..

• Never: .Select this so that the link generated for this item will never expire. 

• After specifying the desired options for each selected item, press "Generate" button so that the 
respective links are generated.

• Respective Item Name (Folder Name or Document Name) and Link Generated are displayed.

• A link for a document would display the it's content whereas, a link for a folder would display a 
list of immediate documents in it enabling the user to download them one by one.

• A copy button next to each document link facilitates copying corresponding link to clipboard 
(available in Internet Explorer only).

• Users can then paste the copied link on the browser addressbar to view contents.

• Users can forward these links to recipients who can then access the respective items.
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• The user himself can click on the document names to ensure that links are generated correctly.

• Press "Ok" to close widow.

2.14 How to view document/access log
• In Folder/Document List select the document whose log you wish to view. 

• Click on the View Document Log icon [  ] or select from menu File->View Document Log. 

• The page displays a list of activities that were carried out on the document till date. 

• Each entry format is of the type "TimeStamp , User , Action". 

• You can also apply search criteria on the log list . 

• The search can be performed based upon "User" and/or "Date". 

• Search patterns for "User" can be one of the following forms: *sam,sam*,*sam*,samhita. 

• Depending upon the search criteria entered, appropriate log list is displayed. 
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2.15 How to activate a watch feature on a document
• Add Watch helps users keep track of their documents.

• Any operation performed on the document will be notified to the users who have applied watch 
to it.

• The notifications will be in the form of emails to the users,so it is mandatory that the users have 
their email id set in samhita.

• If the email id is not set,the user will not be able to add watch to documents and will need to 
contact his system administrator to set his email id.

• In Folder/Document List select the documents for whom watch is to be applied.

• Click on the add watch icon [  ] or select from menu: File ->Add Watch.

• If watch operation is successful, a message "Watch Added Successfully to selected items" will 
be displayed below in the statusbar.

• In case of any error appropriate error message will be displayed in the statusbar.

• Please note that multiple users can add watch to a single document, but a single user cannot add 
watch to a document more than once.

2.16 How to view a document as HTML document
• This functionality aims at the provision of viewing common document types in your browser 

itself without any support of an external plugins.
• Text contents of Office documents,XML,PDFs can be satisfactorily viewed in the browser.
• For any document type whose text content cannot be displayed, a message "Operation not 

supported the requested file type ." is displayed instead.
• In Folder/Document List select the document whose content is to be viewed .
• Click on the view as html icon [  ] or select from menu: File ->View As HTML. 

2.17 How to Cut/Copy/Paste a document/folder
How to Cut Folder/Document? 

• In Folder/Document List select the folder/document you would like to cut. 

• You can select multiple folder/document. 

• Click on the 'Cut' icon or select from menu Edit>Cut. 

• Successful cut will give the message as 'Cut Action performed successfully' in the 
Folder/Document List Task bar. 

How to Copy Folder/Document?
• In Folder/Document List select the folder/document you would like to copy. 

• You can select multiple folder/document. 

• Click on the 'Copy' icon or select from menu Edit>Copy. 
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• Successful copy will give the message as ' Copy action performed successfully' in the 
Folder/Document List Task bar. 

How to Paste Folder/Document? 
• In Folder/Document List select the folder where you would like to paste. 

• Click on the 'Paste' icon or select from menu Edit>Paste. 

• Successful Paste will give the message as 'The selected items were pasted successfully' 
in the Folder/Document List Task bar. 

2.18 How to delete a document/folder
• In Folder/Document List select the folder/document you would 

like to delete. 

• You can select multiple folders/documents. 

• Click on the 'Delete' icon or select from menu Edit>Delete.

• Successful delete will give the message as 'The selected items 
were deleted successfully' in the Folder/Document List Task bar. 

2.19 How to copy a document/folder to a new location
• In Folder/Document List select the 

folder/document you would like to copy.

• You can select multiple folder/document. 

• Click on the 'Copy To' icon [  ] or select from 
menu Edit->Copy To Folder. 

• Select the folder where you would like to Copy 
the selected items. 

• Press 'Select' to copy the selected items to the 
selected Folder. 

• Press 'Cancel' to abort copying. 

• Press 'New Folder' to create New Folder. 
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2.20 How to move a document/folder to a new location
• In Folder/Document List select the folder/document 

you would like to move. 

• You can select multiple folder/document. 

• Click on the 'Move To' icon [  ] or select from 
menu Edit->Copy To Folder. 

• Select the folder where you would like to Copy the 
selected items. 

• Press 'Select' to copy the selected items to the 
selected Folder. 

• Successful copying to the selected folder will give 
message as 'The selected items were copied 
successfully'.

• Press 'Cancel' to abort copying. 

• Press 'New Folder' to create New Folder.

2.21 How to make a document versionable
• In Folder/Document List select the document you would like to make versioned. 

• Click on the 'Make Versionable' icon [ ] or select from menu Version->Make Versionable. 

• Successful making document versionable will give the message as 
'The selected document is versionable' in the Folder/Document List Task bar. 

• The icon will get changed to the versioned document icon [ ].

• You can also select the folder and make the containing documents versionable.

2.22 How to check-out a document
• In Folder/Document List select the document you would like to CheckOut.

• Click on the 'CheckOut' icon [  ] or select from menu Version->CheckOut. 
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• Successful CheckOut will give the message as 'Checked out operation was performed 
successfully' in the Folder/Document List Task bar. 

• The icon will get changed to the CheckOut document icon [ ]. 

• You can also select the folder and Checkout the containing documents.

2.23 How to check-in a document
• In Folder/Document List select the CheckedOut document you would like to CheckIn.

• Click on the 'CheckIn' icon [  ] or select from menu Version>CheckIn.

• Successful CheckIn will give the message as 'Checked in operation was performed successfully' 
in the Folder/Document List Task bar.

• The icon will get changed to the CheckIn document icon.

• You can also select the folder and CheckIn the containing documents.

2.24 How to undo a checkout on a document
• In Folder/Document List select the checkedout document you would like to undo CheckOut. 

• Click on the Undo CheckOut' icon [  ] or select from menu Version->Undo CheckOut. 

• Successful Cancel CheckOut will give the message as
'Cancel Checked out operation was performed successfully' in the Folder/Document List Task 
bar. 

• The icon will get changed to the versioned document icon. 

• You can also select the folder and Cancel CheckOut the containing documents.
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2.25 How to view version history of a document
• In Folder/Document List select the versioned document for which you would like to view 

history. 

• Click on the 'Version History' icon [  ] or select from menu Version->History. 

• Document History page will be displayed with the versions. 

• Press 'Close' to close the Document History.

• Click on the 'Version History detail' [  ] icon to view the detail of the selected version.

2.26 How to encrypt a document
• In Folder/Document List select the document you would like to encrypt. 

• Click on the 'Encrypt Document' icon [  ]. 

• Enter the Encryption password to encrypt the document 

• Press 'OK' if you would like to encrypt the document. 

• Press 'Cancel' to abort encryption. 
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2.27 How to decrypt a document
• In Folder/Document List select the document you would like to decrypt. 

• Click on the 'Decrypt Document' icon. 

• Enter the encryption password to decrypt the document. 

• Press 'OK' if you would like to decrypt the document.

• Press 'Cancel' to abort decryption.

2.28 How to zip a document/folder
• In Folder/Document List select the document you would like to zip. 

• Click on the Zip Document' icon [ �  ]. 

• Enter the name of the document to be zipped. 

• Press 'Ok' if you would like to zip the document. 

• Press 'Cancel' to abort zipping 

2.29 How to unzip a document/folder
• In Folder/Document List select the document you would like to unzip. 

• Click on the 'Unzip' icon [  ]. 

• Enter the name of the document to be unzipped. 

• Press 'Ok' if you would like to unzip the document. 

• Press 'Cancel' to abort unzipping. 
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2.30 How to email a document
• Select documents you want to be emailed
• Click on the Mail link.
• Click on 'Mail' icon [  ] from the Folder/Document List, Mail page appears with the selected 

documents to be mailed.

• This page allows submitting MAIL jobs to the scheduler. The user can specify the date/time on 
which the job has to be dispatched. If the date is earlier than current date/time, the job will be 
directly dispatched.

2.31 How to fax a document
• Select documents you want faxed
• Click on the Fax link. 
• or Click on 'Fax' icon [  ] from the Folder/Document List, Mail page appears with the 

selected documents to be mailed.

• This page allows submitting FAX jobs to the scheduler. The user can specify the date/time on 
which the job has to be dispatched. If the date is earlier than current date/time, the job will be 
directly dispatched.
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2.32 How to submit a document/folder to a workflow
• In Folder/Document List select the document for workflow submission. 

• Click on the Submit to Workflow icon [  ] or select from menu File->Submit To Workflow. 

• Please note it is mandatory that the user's Workflow Acl must be set as well as valid. 

• If this is not the case,then the user must contact System Administrator. 

• User can view the status of his document by viewing Notification page. 
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Chapter 3: User Administration

3.1 Introduction:
Samhita users are accounts created in the product to maintain their files and Documents in a structured 
way. Samhita user accounts can be one of three types: 

• Regular  users:   are  the  end users  who will  store  and  retrieve  files  or  other  objects  in  the 
repository. 

• Administrators:   are the people with privileges to all content and other objects in the repository 
who can provide other users with the privileges needed to get their jobs done. Administrators 
manage the users, folder structure, files, themes and access privileges. 

• System Administrators:  are the people with privileges to start, stop, and monitor the Oracle 
CM SDK domain controller, nodes, services, servers, and agents (through the Oracle Enterprise 
Manager  Website),  and  who  can  reconfigure  these  components  as  needed.  System 
administrators also have complete Administrator privileges. System administrator's access and 
control an Oracle CM SDK instance using the Oracle Enterprise Manager Website. The default 
account that is created during installation for this set of privileges is the system account. 
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3.2 How to find a user:
• Enter search condition in 'Search by User Name' either full User Name or the starting words can 

be entered to search for related Users. (You can also use wild card characters '*' or '?') 

• The Users will be displayed in the User List which matches the entered text. 

• If the search condition doesn't matches page will be displayed with text 'There is no item to 
display'. 

3.3 How to create a new user:
• You can create one user at a time. 

• Click on 'New User' Icon [  ] from the User List, New User Page appears with default 
settings. 
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Note: 
• A user's home folder is the default directory where a user starts when logging into the 

application. 
• The Email User Profile specifies the user's mail folder location and address.
• Unless you change the default definitions, a user's e-mail folder is created under the 

home folder. For example, /home/jsmith/mail. 

3.4 How to modify a user:
• You can Edit one user at a time. 

• Click on 'Edit User' Icon [  ] from the User List, Edit User Page appears with previously 
saved data. 

35



3.5 How to Delete a user:
• Select an User from the User list, Click on 'Delete User' icon [  ] , the User will be deleted, 

User list will get refreshed and will appear with the message in the status Bar as "User 'Steffia' 
successfully deleted." 

3.6 How to change user preferences:
• User Preference is the profile of the logged-in user where information related to his profile is 

displayed. 

• The preferences of the logged-in user can be set like 
• 'Login Password'. 
• 'Watch Documents'. 
• 'Encrypt/Decrypt Password'. 

• 'Permitted tree access level'. 
• 'Items to be displayed per page'. 
• 'Themes'. 
• 'Open Document In New Window '. 
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Chapter 4: Group Administration

4.1 Introduction:
• Groups are composed of users that are related in some way. For example, the Marketing group 

might contain all of the members of the corporate marketing organization. 

• Groups simplify user management. Instead of adding each user to an ACL for a file or folder, 
you can add a group of users all at the same time. Samhita product is shipped with WORLD, a 
default group. When users are created, they are automatically added to this group. To create a 
group, you define the group itself, then populate it. Group names are unique within the owner's 
set of groups. 

• The default ACL of the user that created this group is assigned to any new group the user 
creates. If you need to change the default ACL, you can do so by modifying the ACL for a 
specific group
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4.2 How to find a group
• Enter search condition in 'Search by Group Name' either full Group Name or the starting words 

can be entered to search for related Groups.(You can also use wild card characters '*' or '?'.) 

• The Group(s) will be displayed in the Group List which match the entered text. 

• If the search condition doesn't match,a page will be displayed with text 'There is no item to 
display'. 

4.3 How to create a new group
• You can create one group at a time. 

• Click on New Group icon [  ] from the Group List, New Group Page appears with default 
settings. 

4.4 How to modify a group:
• You can edit one group at a time. 

• Click on 'Edit Group' icon [  ] from the Group List, Edit Group Page appears with 
previously saved data. 
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4.5 How to delete a group:
• Select a Group from the Group list, Click on 'Delete Group' icon [   ] , the Group will be 

deleted, Group list will get refreshed and will appear with the message in the status Bar as 
"Group 'Marketing' successfully deleted". 
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Chapter 5: Security Administration

5.1 Introduction and what is Access Control List (ACL)
• Access  permissions  on  *PublicObjects  are  managed  with  AccessControlLists  (ACL's). 

Whenever  a  user  tries  to  access  a  *PublicObject,  It  first  checks  the  associated 
AccessControlList to verify that the user has been granted the appropriate permissions.

• An AccessControlList is a list of users and groups who have been granted or revoked access 
permissions  to  the  *PublicObject.  Each  time  a  user  or  group is  granted  or  revoked access 
permissions, an entry is added to the AccessControlList.

• In most cases, the standard ACL's that come with application should meet your needs, and the 
remaining cases can be handled by creating a new ACL.

• Application  resolves  a  user's  effective  access  to  a  *PublicObject  by  aggregating  the 
AccessControlEntries  in  the  order  that  they  were  created  in  the  AccessControlList.  Each 
AccessControlList  is  defined  independently  and  applied  to  one  or  more  *PublicObjects, 
allowing you to centrally manage common security levels for *PublicObjects. Any user can 
create an AccessControlList. When an AccessControlList is created, the user can determine who 
else  can  apply  the  AccessControlList  to  *PublicObjects  and  manage the  AccessControlList 
entries.  In  this  way,  users  can  create  personal  AccessControlLists  that  they  use  to  manage 
access to their information, or share AccessControlLists to manage access to information that 
they  collaborate  on  with  other  users.  Typically,  a  *PublicObject  has  only  one 
AccessControlList. When a user tries to access the *PublicObject, all AccessControlLists will 
be used to resolve the user's permissions. While AccessControlLists can be used to grant and 
revoke  standard  permissions  defined  by  Application,  including  Discover,  GetContent, 
SetAttribute, SetContent, and Delete, Application allows you to define custom permissions.
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5.2: How to search for an ACL:
• Enter search condition in 'Search ACL' either full  ACL Name or the starting words can be 

entered to search for related ACL's.(You can also use wild card characters '*' or '?')

• The ACL will be displayed in the ACL List which match the entered text.

• If the search condition doesn't match,a page will be displayed with text 'There is no item to 
display'.
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5.3 How to create a new ACL:
• You can create one ACL at a time.

• Click on 'New ACL' icon [ ] from the ACL List, New ACL page appears with the default 
settings.

5.4: How to Edit an ACL:
• You can edit one ACL at a time.

• Click on 'Edit ACL' icon [  ] from the ACL List, Edit ACL page appears with default 
settings.
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5.5 How to Delete an ACL:
• Select an ACL from the ACL list, Click on 'Delete ACL' icon [  ], the selected ACL will be 

deleted, ACL list will get refreshed and will appear with the message in the status Bar as "ACL 
'SteffiaAcl' successfully deleted." 

5.6 What is Permission Bundle:
• To manage access more broadly than the permissions defined by AccessLevel, you can use 

PermissionBundle to group AccessLevels. PermissionBundles are stored persistently in the 
database, and can be used to represent higher level security settings which may be granted to 
users. 

• For example, you might group the Discover, Add Item, and Remove Item permissions together 
into a ModifyFolder Permission Bundle to more easily grant users the ability to modify folders. 

5.7 How to Search Permission Bundle:
• Enter search condition in 'Search Permission' either full Permission Bundle Name or the starting 

words can be entered to search for related Permission Bundle.
(You can also use wild card characters '*' or '?') 

• The Permission Bundles will be displayed in the Permission Bundle List which match the 
entered text. 

• If the search condition doesn't match,a page will be displayed with text 'There is no item to 
display'. 
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5.8 What is Permission Bundle List:
• Permission Bundle List consists of the Permission Bundles.

5.9 How to create a Permission Bundle:
• You can create one Permission Bundle at a time. 

• Click on 'New Permission Bundle' icon [  ] from the Permission Bundle List, New 
Permission Bundle Page appears with default settings. 
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5.10 How to Edit a Permission Bundle:
• You can edit one Permission Bundle at a time. 

• Click on 'Edit Permission Bundle' Icon [  ] from the Permission Bundle List, Edit Permission 
Bundle Page appears with the previously saved data. 

5.11 How to Delete a Permission Bundle:
• Select a Permission Bundle from the Permission Bundle list, Click on Delete 'Permission 

Bundle' icon, the Permission Bundle will be deleted, Permission Bundle list will get refreshed 
and will appear with the message in the status Bar as "Permission Bundle 'BundleName' 
successfully deleted." 
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Chapter 6: Scheduler

6.1 Introduction:
• Scheduler is the background process responsible for scheduling mail/fax jobs. Scheduler keeps 

track of the entire scheduled jobs and dispatches them on the specified DateTime. 

6.2 How to Start/Stop the scheduler
• In Scheduler List there is a toggle icon which stops the scheduler if it is currently started and 

vice versa. 

6.3 Search a Job
Job search can be done with following criteria: 
• User: Enter the name of the user who created the job. 

• Job Type: Select the type of job that is MAIL,FAX or ALL. 

• Created Date: 
• From: Enter the 'From' create time/date for job as search criteria. 
• To: Enter the 'To' create time/date for job as search criteria. 

• Dispatch Date: 
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• From: Enter the 'From' dispatch time/date for job as search criteria. 
• To: Enter the 'To' dispatch time/date for job as search criteria. 

• The jobs which match the given criteria will be displayed in the joblist. 

• If the search condition doesn't match,a page will be displayed with text 'There is no item to 
display'. 

• All the search criteria given above are optional and can be given in any combination.
If none is given then a list of all the jobs will be listed. 

6.4 Create a new Job
• Scheduling is done through the Mail & Fax Interface. For scheduling a job you either create a 

mail job or a fax job. 

6.5 Reschedule a new Job
• n Scheduler List first select the Job to be re-scheduled. 

• Click on the 'Re-schedule a job' Icon [  ]. 

• Re-schedule job page will be displayed. 
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• Change the date/time for 'Dispatch Date:' 

• Press 'Ok' to reschedule the Job. 

• Press 'Cancel' to abort changes. 

6.6 Delete a Job
• Select a Job from the Job list, Click on Delete Job Icon [  ] , the Job will be deleted, Job list 

will get refreshed and will appear with the message in the status Bar as Job successfully deleted. 
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Chapter 7: Mail and Fax

7.1 Introduction
• Mail and Fax allows you to email or fax a document.

• Email or Fax functionality can be access in two ways:

• First, select Mail or Fax icon from the Users Home Page

• Second, select documents and click on mail or fax icon on the toolbar

7.2 How to create a mail job:
• Click on the Mail link. 

• or Click on 'Mail' icon [  ] from the Folder/Document List, Mail page appears with the 
selected documents to be mailed.

• This page allows submitting MAIL jobs to the scheduler. The user can specify the date/time on 
which the job has to be dispatched. If the date is earlier than current date/time, the job will be 
directly dispatched.

50



7.3 How to create a fax Job:
• Click on the Fax link. 
• or Click on 'Fax' icon [  ] from the Folder/Document List, Mail page appears with the 

selected documents to be mailed.

• This page allows submitting FAX jobs to the scheduler. The user can specify the date/time on 
which the job has to be dispatched. If the date is earlier than current date/time, the job will be 
directly dispatched.
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Chapter 8: Workflow

8.1 Introduction
• Workflow  automates  and  streamlines  business  processes  contained  within  and  between 

enterprises. 

• For example, you can use workflow processes to: 

    Add personalized trading partner rules

    Validate self-service transactions

    Achieve closed loop business intelligence

    Approve standard business documents

    Step through daily transaction flows

    Integrate with trading partner systems

• Workflow lets you focus on managing business processes,not individual transactions. 

• Samhita  workflow has  been modelled in  such a  way that  it  can accomodate both types  of 
workflow ie

    1) Where only one approver is present.

    2) Where a list of approvers are present according to a hierarchy

When a list of approvers are present according to a hierarchy,the workflow process takes the 
approval  requisition  from  one  approver  to  his  immediate  senior(if  the  previous  approver 
approves it)  else rejection by any approver leads to the rejection of the requisition and the 
requestor is notified.

The last person in this hierarchy is the final approver.If he decides to approve the document, the 
document is finally approved and a notification is sent to the requestor.

The  requestor  also  gets  the  notification  regarding  the  movement  of  document  along  the 
hierarchy.

8.2 How to use Workflow:
Following are the necessary steps for using workflow 

1) First create an ACL for the list of approvers: Create a permission bundle named "approver" 
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with GetContent and Discover permissions.Create an ACL with list of users which will act as 
approvers  in  the  same  hierarchy  as  the  organizational  structure  with  grant  on  "approver" 
permission bundle(if there is only one approver then only one entry will be there in this acl).The 
last person/user in this ACL is the highest in the hierarchy.This particular ACL's name should 
start with "wf". 

2) Edit the user who will act as requestor and select the workflow ACL for him.Save the 
settings. 

3) Now the user is workflow enabled and he can submit docs for approval. 

4) Go to the document page with requester logged in and select one document and click on 
"Submit to workflow icon"[  ] or select from menu File->Submit To Workflow. 

5) Now the requester can go to his notifications page and view the document status and its 
movement. He shall also get the final result as notification ie(approved or rejected). All the 
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notifications for the requester will be of type FYI. 

6) Meanwhile the first person in the list of approvers gets the notification on which he can 
respond by clicking approve or reject button. 

7) If it is approved the requisition goes to the next approver and the cycle continues until the 
document is either rejected by anyone of them or it is approved by all of them, after which the 
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doc is considered approved. 
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Chapter 9: Adapters

9.1 Introduction:
Adapter facilitates integration of various ERP applications and Samhita. 

• At present,Samhita provides tight integration with People Soft Financials , People Soft HR and 
SAP. 

• Inorder to access adapters , click on the "Adapter" [  ] icon on the home page. 

• A page with various appropriate enabled adapters is displayed as shown below. 

Sample Adapter Screen
  

• Here , "PS Fin" and "PS HR" are enabled adapters while "SAP" is the disabled adapter. 
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• Not every user has adapter access by default. Only those users whose name appear in adapter 
specific ACLs will be able to access adapters. 

9.2 Adapter Preferences:
Adapter Preference is the user interface through which system administrator can manage adapters in 
samhita. 

• The preferences can be set for 
• Enabling / Disabling Adapters 
• Managing Folders For Adapters 

9.3 How to enable/disable an adapter:
Inorder to enable adapters, 

• Select the desired adapters from "Available Adapters "and move them to "Enabled Adapters" 

• Click "Save" below "Enabled Adapters" in fig 1 to save the changes made 

Inorder to disable adapters, 

• Select the desired adapters from "Enabled Adapters "and move them to "Available Adapters" 

• Click "Save" below "Enabled Adapters" in fig 1 to save the changes made 
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9.4 How to manage folders for adapter:

 
To create a new screen key for an enabled adapter:

• Select the adapter from the dropdown next to "Manage Folder For" as shown in fig 1 

• Select "Manage Folder For" option as shown in fig 1 

• Enter a new and unique Screen Key 

• Select the desired folder to which this key should correspond using the Look In... button 

• Once the screen key and folder path have been entered, Click "Save" adjacent to the Look In... 
button in fig 1 to create and save the key 

To view the list of screen key(s) for an enabled adapter:

• Select the adapter from the dropdown next to "Manage Folder For" 

• Click "View List" to view the list of screen keys and the corresponding folder paths 

To delete screen key(s) for an enabled adapter:

• Select the adapter from the dropdown next to "Manage Folder For" 

• Click "View List" to view the list of screen keys and the corresponding folder paths as shown in 
illustration.

• Select the key(s) to be deleted and press "Delete" to delete the same 

• Please note that deleting key(s) does not delete the corresponding folder(s)
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Chapter 10: Themes

10.1 Introduction:
Theme helps in customizing user interface by selecting the supplied or customizable themes. 
Theme consists of 4 parts:

• Style 
• Color scheme 
• Fonts 
• Backgrounds 

Only Super Users (Administrator) have rights to create/modify/delete Themes. Normal Users 
can only select the Theme for themselves.
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10.2 How to apply theme:
• Click Preferences 
• Select the Theme from 'Select a Theme' option in the User Preference page. 
• Press 'Preview' to see the preview of the Theme selected from the above mentioned option. 
• Press 'OK' to apply the changes to the User-Interface. 
• Press 'Cancel' to go back to the previous page accessed. 

Note: To Create, Modify or Delete a theme, user should have access rights to Themes.

10.3 How to Search a theme:
• Enter search condition in 'Search by Theme' either full Theme Name or the starting words can 

be entered to search for related Themes.
(You can also use wild card characters '*' or '?')

• The Themes will be displayed in the Theme List which match the entered text.

• If the search condition doesn't match,a page will be displayed with text 'There is no item to 
display'.

10.4 What is Theme List:
• Theme List is list of supplied and customizable Themes.
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10.5 How to create a Theme:
• Click on 'New Theme' icon [  ] from the Theme List, New Theme Page appears with default 

settings. 

Select the Theme Elements. 
• Styles:Choose a Style from the Choices box and 

corresponding ColorScheme for the selected Styles.

• Fonts: Choose font from the corresponding combo 
and color for Heading Text, Body Text, Bold Text 
and Element Text.

• Backgrounds: Choose either color or image from 
'Select a Background' option. 

• Color: Choose the color which you would like to keep as background color from the color 
palette. 
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• Image: Choose the image which you would like to keep as background from the list of images. 

• Theme Name: Enter a unique Theme Name, It is a mandatory field. 

• Press 'Preview' to see the preview of the Theme. 

• Press 'Save' to save the newly created Theme, the Theme will be saved and Theme list will 
appear with the message in the status Bar as "Theme 'StandardDesert' successfully saved". 

• Press 'Cancel to abort New Theme creation. 

10.6 How to edit a Theme:
• Click on 'Edit Theme' icon [  ] from the Theme List, Edit Theme Page appears with 

previously saved data. 

Now select the Theme Elements. 
• Styles:Choose a Style from the Choices box and corresponding ColorScheme for the selected 

Styles. 

• Fonts: Choose font from the corresponding combo and color for Heading Text, Body Text, 
Bold Text and Element Text. 
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• Backgrounds: Choose either color or image from 'Select a Background' option.

• Color: Pick the color which you would like to keep as background color from the color palette. 

• Image: Choose the image which you would like to keep as background from the list of images. 

• Press 'Preview' to see the preview of the Theme. 

• Press 'Save' to save the modified Theme, the Theme will be saved and Theme list will appear 
with the message in the status Bar as "Theme 'StandardDesert' successfully saved". 

• Press 'Cancel' to abort changes done on the Theme. 

10.7 How to Delete a Theme:
• Select a theme from the theme list, Click on 'Delete Theme' icon [  ] , the theme will be 

deleted, then the theme list will get refreshed and will appear with the message in the status Bar 
as "Theme 'ClassicDesert' successfully deleted".
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Appendix A: Using Peoplesoft Financials Adapter

A.1 Introduction:
Samhita, a comprehensive and user-friendly framework that can quickly and cost-effectively leverage 
your technology investments enhancing your existing business process by storing documents, vouchers 
and invoices, linking them to the appropriate records. Making information accessible with a single click 
from your existing software application enhancing work processes in areas such as accounts payable, 
procurement, customer service, compliance and many others. 

Samhita comes with various adapters that make integration of samhita with other application easier. 
One of such adapter is Peoplesoft Financial adapter. This adapter can be used to automate some of the 
key business processes in the Peoplsoft Financials. One of such process is Accounts Payable invoice 
processing. Samhita allows you to streamline invoice processing by removing common paper-related 
bottlenecks. Samhita lets staff bind receipts and invoices electronically to their respective transactions 
in your accounts payable software and access those documents instantly from a central repository. A 
strong workflow ensures routing of items through the approval cycle more efficiently.

This streamlined invoice processing is achieved by following few steps. The first step is to import and 
capture invoice data. Paper invoices are in multiple forms and need to be transformed into images via 
scanning and then submitted to rigorous image preprocessing, or cleanup, to ensure that data is easily 
readable and accurate as it moves through the system.

The invoice captured in the first step, then is store in Samhita system in a logical folder structure. At 
this point a link is generated to this stored invoice, which would allow one to access the invoice.

Link generated in the second step is incorporated in the Accounts Payable(AP) system. This would 
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enable a filing clerk or an auditor to access the physical invoice by clicking on the link.

A.2 How to submit vouchers to the workflow:
• Make  sure  you  have  requisite 

privileges  to  submit  documents  to 
workflow.

• Scan  all  the  invoices  received  as 
paper.

• Upload all the images to Samhita into 
a folder.

• Select  the  folder  into  which  all  the 
images are uploaded

• Click on Submit Workflow icon

• Select the appropriate workflow based 
on a queue

• Click on OK

A.3 How to enter vouchers in the Peoplesoft:
• Make sure you have web browser pop-up blocker disabled for samhita website.

• Login into Peoplesoft

• Navigate to Voucher Data entry screen

• Create a new voucher (Follow the illustrations)
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• Click on “Get Next Image” button
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• A new image should open in a separate window

• Perform data entry by looking at the image

• Save the voucher

• The Voucher image is permanently a tied to the recently created voucher in Peoplesoft, which 
can be viewed by clicking on the “Show Image” button.
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A.3 How to monitor voucher queues:
• To be able to perform this operation you should have queue management rights

• Login into Samhita

• Click on Adapters

• Click on Peoplsoft Financials adapter

• Select the Voucher Reports tab.

• Select the Zone (queue) for which you want the report for.

• Click on the Generate button

• You should be presented with a screen showing a bar chart showing the status of the whole 
voucher process.

A.4 How to administer voucher queue:
Some times  you need  to  reset  the  voucher  status  from “in-process”  to  “in-queue”  again.  This 
situation arises when AP data entry personnel clicks on “Get next image” button in peoplesoft, but 
does not perform the data entry leaving the voucher status to “in-process”

• To be able to perform this operation you should have queue management rights

• Login into Samhita

• Click on Adapters
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• Click on Peoplsoft Financials adapter

• Select appropriate queue (zone)

• Select vouchers you want to reset

• Click on reset icon to reset selected vouchers

A.5 How to create new queue:
• In order to be able to perform this operation you must have system administration provileges.

• Login to the Samhita as system administrator.

• Click on Security icon

• Click on create new ACL
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• Create a new ACL with a new name, with ACL Type as “Peoplesoft Financial”.

• Add users who will be the queue managers in the ACL

• Click on the Save button.
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